As I understand it you always need to use the full "path" name when accessing child variables in a parent or when using built-in functions
eg iformbuilder.math.sum(table_name.subform_element_dcn, 'element_on_subform')
It's the same for passing data around.
It would be much better for reuse and supportability if there was a mechanism to state <current_record> and hence use not explictly state the parent table & path.
eg iformbuilder.math.sum($current_record.subform_element_dcn, 'element_on_subform')
where $current_record is evaluated as the name of the parent table (and any higher level parent records).
Please sign in to leave a comment.